GNU 이미지 조작 프로그램 (GIMP)은 디지털 이미지 파일 (예, 사진, 스캔 이미지, 컴퓨터 합성 이미지 등)을 만들거나, 수정, 조작, 개선하는 강력한 이미지 작업 도구입니다. 이 장에서는 GIMP에 대하여 간략한 소개와 함께 GIMP에 대한 보다 자세한 정보를 찾을 수 있는 참조 자료를 제공해 드립니다.
GIMP를 사용하기 위해서는, 몇 가지 기본 사항을 알아야 할 필요가 있습니다. 쉘 프롬프트에서 gimp 명령을 사용하여 GIMP를 시작할 수 있습니다. GIMP를 시작하려면 데스크탑 패널에서 주 메뉴를 선택하신 후 => 그래픽 => The GIMP를 선택하시면 됩니다.
그림 11-5은 실행 중인 전형적인 GIMP 세션을 보여줍니다.
기존 파일을 불러 들이려면, 파일 => 열기를 클릭하십시오. 그림 11-6에서 보여지듯이 이미지 불러들이기 대화 상자가 나타납니다.
이미지 불러들이기 대화 상자는 현재 여러분이 작업하고 있는 디렉토리 — GIMP를 실행시 여러분이 위치했던 디렉토리를 보여줍니다. 왼쪽에 있는 디렉토리(Directories) 목록을 더블 클릭하여 파일 시스템 항목을 위/아래로 살펴보실 수 있습니다. 그 후 오른쪽에 있는 파일 목록에서 파일을 선택하여 엽니다.
GIMP는 파일명 완성기능을 지원합니다. 만일
선택 영역에 파일명 중
첫번째 글자를(또는 이상) 입력하고
선택된 파일은 대화 상자의 아래쪽에 있는 선택 영역에 나타나며 대화 상자에는 작은 미리보기 화면이 나타납니다; 다른 방법으로 미리보기 생성 버튼을 클릭하시면, 작은 이미지 미리보기가 나타납니다.
일단 파일 선택이 완료되면, 확인 버튼을 눌러 그 파일을 열 수 있습니다. 파일명을 더블 클릭하여 파일을 여는 방법도 있습니다.
이미지 파일을 저장하기 위해서는 이미지를 오른쪽 클릭한 후 파일 => 저장 (또는 다른 이름으로 저장)을 선택합니다. 만일 이전에 저장한 적이 없는 파일을 저장 버튼을 눌러 저장하거나 또는 다른 이름으로 저장 버튼을 선택하면, 이미지 저장 대화 상자가 나타날 것입니다.
이미지 저장 대화 상자는 이미지 불러들이기 대화 상자와 매우 유사하며 파일 시스템 구조와 파일을 선택하는 방식은 동일합니다.
이미지를 저장시 이미지 형식을 선택하셔야 합니다. GIMP는 .gif, .png, .jpg, .bmp와 같은 다양한 이미지 형식을 지원합니다.
많은 다른 응용 프로그램과 마찬가지로 GIMP도 한 가지 이상의 작업 수행 방법을 갖추고 있습니다. 가장 쉬운 이미지 작업 방법은 이미지에 오른쪽 클릭하는 것입니다. 이렇게 하면 이미지 크기 조절, 회전과 필터 응용 프로그램과 같은 다양한 GIMP 기능이 포함된 메뉴 모음이 나타날 것입니다.
예를 들어 여러분이 가지고 계신 사진을 조작하여 마치 신문에서 오려낸 것처럼 보이게 하고 싶다고 가정해 봅니다. 이렇게 하기 위해서는, 이미지를 오른쪽 클릭하시고 Filters => Distorts => Newsprint...를 선택합니다. 좌우 이동 막대를 이용하여 1 인치당 줄의 숫자를 선택하십시오. 원하는 양을 선택하고 이미지를 표시할 준비가 되었다면, 확인 버튼을 클릭합니다. GIMP는 새로운 효과를 이미지에 적용합니다. 그림 11-7에서 Newsprint 필터가 적용된 이미지를 볼 수 있습니다:
도구상자 또한 쉽게 사용할 수 있는 여러가지 기능을 갖추고 있습니다. 도구상자를 이용하여 여러분은 이미지에 텍스트를 추가하고, 이미지의 일부를 지울 수 있으며 또한 선택한 부분을 원하는 색상으로 채울 수도 있습니다.
예를 들어 파일에 텍스트를 추가하시려면,
버튼을 선택하신 후 이미지를 클릭하십시오. 이렇게 하시면
텍스트 도구 대화 상자가 대화 상자가 나타날 것입니다. 이 대화 상자에서
글꼴을 선택하신 후 제공된 입력란에 텍스트를 입력하실 수 있습니다. 확인 버튼을
클릭하시면 입력하신 텍스트가 이미지 위의 떠있는 부분에 표시될 것입니다. 그 후 Move Layers를
사용하여 원하는 위치로 텍스트를 이동시킬 수 있습니다. 그림 11-8에서는 흥미로운 텍스트가
추가된 저희의 사진을 볼 수 있습니다:
이미 보셧듯이, GIMP는 강력한 이미지 편집 도구이며 GIMP의 모든 기능을 완전히 익히기 까지는 시간이 걸릴 것입니다. 여러 옵션을 스스로 사용해 보십시오. 실수를 한다고 해도 걱정하실 필요가 없습니다. 언제든지 이미지를 오른쪽 클릭하거나 편집 => 취소를 선택하여 실수를 취소할 수 있습니다.