Red Hat Linux에는 다양한 문서 관리 도구가 포함되어 있습니다. 따라서 여러분이 학교나 기업체에서 발표를 준비하신다거나, 이메일 첨부 파일로 보내온 문서를 열고, 공적 업무용 서신을 작성하실 때와 같은 다양한 경우에, Red Hat Linux는 여러분의 필요에 맞는 도구를 제공해 드립니다.
사무용 도구는 여러분이 학교, 사무실이나 가정에서 문서 작업을 보다 효율적으로 사용하실 수 있도록 도와주는 응용 프로그램의 모음입니다. 사무용 도구는 기본적으로 그래픽으로 구성되어 있으며 워드 프로세서, 스프레드시트와 프리젠테이션 유틸리티를 포함합니다. 사무용 도구에 포함된 응용 프로그램들은 통합되어 있습니다. — 즉, 워드 문서를 작업하면서 스프레트시트 응용 프로그램을 사용하여 만든 도표를 삽입하고 그래픽 프리젠테이션 응용 프로그램에서 슬라이드를 가져와서 삽입 가능합니다. 이러한 소프트웨어의 통합성 덕분에 여러분은 더욱 손쉽게 멋있는 문서나 프리젠테이션 자료를 작성하실 수 있습니다.
Red Hat Linux에는 강력한 사무용 도구인 OpenOffice.org가 포함되어 여러 다양한 응용 프로그램들을 하나의 통합된 패키지로 묶어 줍니다. 따라서 복잡한 태그(tag)나 코드를 사용하여 문서를 직접 포맷하시는 것보다 OpenOffice.org를 사용하시면, 훨씬 빠르고 쉽게 문서를 작성하실 수 있습니다. 이 사무용 도구는 문서의 내용과 배치 양식을 여러분 마음대로 조절할 수 있도록 해주며 여러분이 편집하시는 내용을 실시간으로 보여줍니다. 이처럼 편집중인 문서의 결과물이 어떤 모습으로 나타날 것인지를 작업 중에도 볼 수 있도록 해주는 것을 WYSIWYG (what you see is what you get의 줄임말) 편집하기라고 부릅니다.
OpenOffice.org 프로그램 모음에는 문서, 스프레드시트, 사무용 프리젠테이션과 그래픽 이미지를 만들고 편집하는데 사용되는 다양한 응용 프로그램이 포함되어 있으며, 이러한 응용 프로그램은 여러분이 보다 쉽고 빠르게 기본 사무용 문서와 프리젠테이션을 생성할 수 있도록 템플릿, 양식과 마법사를 제공합니다. 만일 이전에 .doc 이나 .xls 파일 작업을 해보셨다면, 이 파일들은 Microsoft Office 프로그램 모음 관련 파일이라는 것을 이미 잘 알고 계실 것입니다. OpenOffice.org 프로그램 모음은 이러한 Microsoft Office 파일을 비롯한 다양한 형식의 파일을 읽고, 편집하고 생성할 수 있습니다. 표 9-1을 보시면 OpenOffice.org 프로그램 모음을 사용하여 작업 가능한 여러 다른 형식의 파일의 목록이 나와 있습니다.
| 응용 프로그램 | 파일 호환성 | 문서 형식 |
|---|---|---|
| OpenOffice.org Writer | .sxw, .sdw, .doc, .rtf, .txt, .htm/.html | 공식 서신, 사무용 양식, 시험지, 이력서, 뉴스레터, 리포트 |
| OpenOffice.org Calc | .sxc, .dbf, .xls, .sdc, .slk, .csv, .htm/.html | 스프레드시트, 차트, 표, 그래프, 전화번호부, 주소록, 영주증과 계산서, 예산안, 단순한 데이터베이스 |
| OpenOffice.org Impress | .sxi, .ppt, .sxd, .sdd | 기업체와 학교 프리젠테이션, 웹 프리젠테이션, 강의 자료, 슬라이드 쇼 |
| OpenOffice.org Draw | .sxd, .sda; .jpg, .bmp, .gif, .png와 같은 다양한 이미지 형식으로 파일을 변환 가능 | 일러스트레이션, 선 그리기, 클립 아트, 기업체 부서 조직도 |
표 9-1. OpenOffice.org 기능
위의 목록에서 보실 수 있듯이, OpenOffice.org 프로그램 모음은 많은 파일 호환성 기능을 갖추고 있기 때문에 학교, 기업체, 가정에서 필요한 다양한 작업을 수행하실 수 있습니다. 다음 섹션에서는 OpenOffice.org 프로그램 모음을 사용하는 방법에 대하여 다루어 보겠습니다.
OpenOffice.org를 사용하여 문서를 작성하는 방식은 여러분이 지금까지 사용해 오셨던 다른 워드 프로세서와 유사합니다. 워드 프로세서는 텍스트 편집기와 비슷하지만 복잡한 포맷팅 태그나 코드를 기억할 필요없이 문서를 포맷, 디자인하고 인쇄할 수 있도록 해주는 여러 추가적인 기능을 갖추고 있습니다. OpenOffice.org Writer는 강력한 워드 프로세서로서 WYSIWYG 포맷팅 — 즉, 현재 OpenOffice.org Writer 창에서 편집중인 문서가 인쇄되었을 때, 또는 다른 사람에게 문서 파일로 보내졌을 때 어떤 모습으로 나타날 것인지를 작업 중에도 볼 수 있도록 해줍니다. 그림 9-1에서는 실행 중인 OpenOffice.org Writer를 보실 수 있습니다:
데스크탑 패널에서 OpenOffice.org Writer를 시작하시려면, 주메뉴 => 오피스 => OpenOffice.org Writer를 선택하십시오; 쉘 프롬프트에서 실행하시려면, oowriter 명령을 입력하시면 됩니다.
기본 인터페이스는 문서 편집 공간입니다 (텍스트를 입력할 수 있는 창 가운데 백지 공간을 말합니다). 창 상단에는 글꼴, 용지 크기, 정렬 (왼쪽 정렬, 가운데 정렬, 오른쪽 정렬) 기능을 조절하는 도구바와 그 외 다른 텍스트 포맷팅 버튼이 위치합니다. 또한 원하는 문서 파일의 위치를 입력하여 그 파일을 불러올 수 있는 텍스트 박스와 기존 파일 열기, 저장, 인쇄하기를 비롯하여 새 문서 만들기 (새로운 내용을 입력할 수 있는 백지 문서가 새 창에서 열립니다)에 사용되는 버튼도 찾으실 수 있습니다.
창 왼쪽을 보시면, 맞춤법 검사와 철자가 틀린 글자를 자동으로 찾기, 단어와 구문 검색와 같은 편리한 편집 기능을 위해 사용되는 버튼이 모인 도구바가 있습니다. 도구바 버튼 위에 마우스를 올려 놓으시면, 각 버튼의 기능에 대한 간략한 설명이 조그만 힌트 팝업 창에 나타납니다. 보다 자세한 설명을 원하신다면, 도움말 메뉴를 클릭하신 후 확장된 설명을 선택하시기 바랍니다.
기본 설정을 사용하여 문서 편집 영역에서 텍스트를 바로 입력하실 수 있습니다.
작성하신 텍스트를 저장하시려면, 저장 버튼
을 클릭해 주십시오. 파일 형식을 변경하시려면 파일 유형 드롭다운 메뉴에서
알맞은 파일 형식을 선택해 주십시오. OpenOffice.org 응용 프로그램만 사용하여
작업할 파일은 기본 파일 유형을 사용하시기 바랍니다. 그러나 만일 Microsoft Office를 사용하는 사용자에게 파일을 보내시거나,
이메일에 첨부된 .doc 확장자를 가진 파일을 편집하시는 경우에는 다른 사용자가
Microsoft Word 응용 프로그램으로 그 문서를 열 수 있도록
Microsoft Word 파일 형식으로 저장하셔야 합니다.
OpenOffice.org Writer는 일반 용도의 문서 편집 작업에 유용하게 사용될 뿐만 아니라 텍스트를 더욱 멋지고 인상깊게 꾸미기 위하여, 문서에 이미지, 일러스트레이션, 차트, 표와 같은 객체를 삽입하는 것도 가능합니다. 이미지를 삽입하시려면, 삽입 => 그래픽 => 파일에서 가??윤?를 클릭하신 후 팝업 파일 탐색창에서 원하시는 이미지를 선택해 주십시오. 커서가 위치한 곳에 이미지가 삽입될 것입니다. 필요에 맞게 이미지 크기를 크거나 작게 재조정하실 수 있습니다. 그림 9-2에서는 문서에 삽입된 이미지를 보여줍니다.
문서 작업을 마치셨으면, 원하시는 형식으로 파일을 저장하실 수 있습니다. 사용 가능한 파일 형식에 대한 정보를 원하시면 표 9-1을 참조하시기 바랍니다. 대부분의 컴퓨터에서 웹 프라우저 (예, Mozilla)나 PDF 보기 프로그램 (예, xpdf 또는 Adobe Acrobat Reader)을 사용하여 읽을 수 있는 HTML이나 PDF 형식으로 문서를 변환하는 것도 가능합니다.
규모가 큰 기업체에서 가정용 사무실에 이르기까지, 모든 산업체에 종사하는 분들이라며 자료를 저장하고, 사업용 도표를 만들고 데이터를 수정하기 위해 스프레드시트를 사용해 보셨을 것입니다. OpenOffice.org Calc은 열과 행으로 구성된 셀 (cells)에 데이터를 입력하거나 입력된 데이터를 수정할 수 있게 해주는 소프트웨어 스프레드시트 응용 프로그램입니다. 이 응용 프로그램을 사용하여 여러 셀의 수치 계산을 동시에 수행 (예, 몇 개의 셀에 포함된 수치를 덧셈하거나 뺄셈하기)하실 수 있으며 여러 셀을 함께 모아서 차트를 만드는 것도 가능합니다. 스프레드시트 데이터를 워드 문서에 삽입하여 보다 전문적인 문서를 만들어 보십시오.
데스크탑 패널에서 OpenOffice.org Calc를 시작하시려면, 주 메뉴 => 오피스 => OpenOffice.org Calc를 선택하십시오. 쉘 프롬프트에서 oocalc 명령을 입력하여 OpenOffice.org Calc 프로그램을 시작하는 것도 가능합니다.
그림 9-3에서는 실행 중인 OpenOffice.org Calc을 보여줍니다.
OpenOffice.org Calc을 사용하여 개인용이나 사업용 데이터를 입력하고 수정하실 수 있습니다. 예를 들어 여러분이 개인 예산안을 작성한다고 가정합니다. A 행에는 데이터에 대한 설명 (예, 집세, 식료품, 생활비)을 입력하시고 B 행에는 개별 데이터의 값을 입력하시면 됩니다. 셀에 데이터를 입력하시려면 해당 셀에 두번 클릭하시거나 입력 줄 (도구바 상의 텍스트 박스)를 사용하여 정보를 입력하실 수 있습니다. 정보 입력을 마치신 후, B 행에 산술 명령을 실행하여 총액을 계산해 보십시오. OpenOffice.org Calc에는 여러가지 산술 계산 함수 (예, 더하기/곱하기: =SUM(), 나누기: =quotient(), 영수증 총액 산출: =subtotal())이 이미 설정되어 있습니다. OpenOffice.org Calc에서 수치 데이터를 계산하는 함수를 생성하는 방법에 대한 자세한 정보를 원하신다면, 도움말 => 내용을 선택하여 문서 자료를 참조해 보십시오.
OpenOffice.org에는 학교 수업 발표용이나 회사에서 프레젠테이션 용으로 차트나 그래프를 만드셔야 할 경우, 사용 가능한 다양한 차트와 그래프 양식이 준비되어 있습니다. 차트로 만들 부분을 하이라이트하신 후 삽입 => 차트...를 클릭하십시오. 차트 창이 나타나 여러분이 선택하신 데이터를 텍스트 상자에 보여줄 것입니다. 원하시면 선택된 데이터를 수정하실 수 있습니다. 다음 버튼을 클릭하시면, 이 데이터를 사용하여 만들 수 있는 다양한 형식의 차트와 그래프를 보여줍니다. 원하시는 유형을 선택하신 후 만들기 버튼을 클릭해 주십시오. 스프레드시트 창에서 그래프가 앵커로 표시됩니다. 이 그래프를 화면 어느곳으로나 이동시킨 후 인쇄하시거나 그래프를 객체로 저장 후 OpenOffice.org Writer 문서나 OpenOffice.org Impress 프레젠테이션에 삽입하실 수 있습니다.
OpenOffice.org Calc를 사용하여 스프레드시트를 Microsoft Office 호환 가능한 .xls 형식을 비롯한 원시 .sxc 형식과 같은 여러 가지 파일 형식으로 저장 가능합니다. 또한 렌더된 차트와 그래프를 여러 이미지 파일 형식으로 보내기한 후 문서 파일, 웹 페이지나 프리젠테이션에 삽입하실 수 있습니다.
OpenOffice.org Calc 사용법에 대한 보다 많은 정보를 원하신다면, 파일 메뉴에서 도움말 => 내용을 열어서 도움말 페이지를 참조하시기 바랍니다.
프리젠테이션 자료에 시각적 효과를 추가하시면 청중의 흥미를 유발시키고 주의 집중할 수 있게 할 수 있습니다. OpenOffice.org Impress는 여러분이 보다 효과적인 발표나 설명을 위한 자료를 준비할 수 있도록 도와주는 그래픽 도구입니다.
그래픽 데스크탑에서 OpenOffice.org Impress를 시작하시려면, 주 메뉴 => 오피스 => OpenOffice.org Impress를 선택하십시오. 쉘 프롬프트에서 OpenOffice.org Impress를 시작하시려면 ooimpress 명령을 입력하시면 됩니다.
OpenOffice.org Impress는 다양한 AutoPilot 기능을 갖추어 있어서 다양한 배경과 형식을 제공하여 여러분은 이를 잘 조합하여 원하는 프리젠테이션 형식을 매우 쉽게 만드실 수 있습니다. 항목별 목록, 아웃라인과 이미지를 사용하여 슬라이브를 생성하실 수 있으며 OpenOffice.org Calc에서 챠트나 그래프를 가져와 슬라이드에 삽입하는 것도 가능합니다.
그림 9-5에서는 실행 중인 OpenOffice.org Impress를 보실 수 있습니다.
OpenOffice.org Impress를 처음 시작하시면, 프레젠테이션 설정 화면이 나타납니다. 이 화면에서 원하시는 프레젠테이션 형식에 대한 기본 정보를 설정해 주십시오. 슬라이드 형식, 슬라이브를 보여줄 매체 (종이, OHP (오버헤드 프로젝터)에 사용되는 투명 용지, 슬라이드, 모니터)와 원하신다면 컴퓨터에서 프레젠테이션할 때 슬라이드에 적용할 시각적 효과도 선택하실 수 있습니다.
AutoPilot 도구를 사용하여 기본 설정을 마치셨으면, 원하시는 유형의 슬라이브를 선택해 주십시오. 목록에서 이미 포맷된 슬라이드를 선택하시거나 공백 슬라이드를 선택하여 스스로 슬라이드 배치를 사용자 설정하실 수도 있습니다. 프레젠테이션에 사용될 새 슬라이드를 만드시려면, 떠있는 도구바에서 슬라이드 삽입... 항목을 클릭하십시오. 나타난 팝업 창에서 새 슬라이드의 배치 구조를 선택하실 수 있습니다. 프레젠테이션에 사용될 수 있는 슬라이드의 수에는 제한이 없기 때문에, 원하시는 만큼 마음껏 만드실 수 있습니다.
프레젠테이션을 미리 보시려면 슬라이드 쇼 =>
슬라이드 쇼를 선택하시면 됩니다.
전체 화면에서 각각의 슬라이드를 순서대로 마지막 슬라이드까지 보여주는 프레젠테이션이 진행되며,
프레젠테이션 도중에 슬라이드 쇼에서 빠져나오시려면
프리젠테이션은 다양한 파일 형식으로 저장될 수 있습니다. OpenOffice.org Impress 형식 (예, mypresentation.sxi)으로 저장할 수 있으며, Microsoft PowerPoint 형식 (mypresentation.ppt)으로도 저장이 가능합니다. 또는 StarImpress 형식 (mypresentation.sdd)으로도 저장할 수 있습니다. 슬라이드를 종이나 투명 용지에 출력하시려면 파일 메뉴에서 파일 => 인쇄를 선택하시면 됩니다.
OpenOffice.org Impress에 대하여 알고 싶으시다면, 도움말 => 내용을 선택하여 도움말을 참조하시기 바랍니다.
문서와 프레젠테이션에 삽입할 그래픽을 만들 때, OpenOffice.org Draw 프로그램을 사용하시면 쉽고 편리하게 만드실 수 있습니다. OpenOffice.org Draw에서 마우스를 이용하여 마치 펜이나 붓으로 그리듯이 그림을 그리신 후 다양한 형식으로 이미지를 저장하여 문서에 삽입하고 웹사이트 상에 올리거나 이메일에 첨부하실 수 있습니다.
데스크탑 패널에서 OpenOffice.org Draw를 시작하시려면, 주 메뉴 => 오피스 => OpenOffice.org Draw를 선택하십시오. 쉘 프롬프트에서 OpenOffice.org Draw를 시작하시려면 oodraw 명령을 입력하시면 됩니다.
그림 9-7에서는 실행 중인 OpenOffice.org Draw를 보여줍니다.
The GIMP와 같은 일러스트레이션 그래픽 프로그램을 이미 사용해 보셨다면, OpenOffice.org Draw의 일부 기본 기능이 동일하다는 사실을 쉽게 알 수 있습니다. (The GIMP와 관련된 보다 많은 정보를 원하시면 11 장 참조하시기 바랍니다). 직선과 곡선, 사각형과 원형과 같은 기본 모양, 원뿔과 정육면체와 같은 3D 물체 등을 그리는데 사용되는 도구바가 위치하고 있습니다. 이미지를 만드신 후 주 도구바에서 영역 유형/채우기 드롭다운 메뉴를 사용하여 그 이미지를 원하시는 색상으로 채워보십시오. 그림에 추가 텍스트를 삽입하는 것도 가능합니다. OpenOffice.org Draw는 또한 외부에서 가져온 이미지를 열어서 제공된 도구를 가지고 수정할 수 있는 기능도 제공합니다.
일러스트레이션이나 이미지 수정을 마치신 후, 파일을 다양한 고유 파일 형식으로 저장하실 수 있으며 또는 .jpg 나 .png와 같이 다른 소프트웨어 에서도 호환되는 형식으로 변환하는 것도 가능합니다. 호환 가능한 이미지 파일 형식의 전체 목록을 보시려면 표 9-1를 참조하시기 바랍니다.
OpenOffice.org Draw 사용법에 대한 보다 많은 정보를 원하신다면, 파일 메뉴에서 도움말 => 내용에 위치한 문서 자료를 참조해 보십시오.